cuir sandales en noires sandales grecques appartements en flip tongs Sandales sandales sandales cuir Womens d cuir en grec 0ZFEgnxwn

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

Sxc01720 Bleu Bleu 5 Plateforme AdeeSu Femme 36 FwT1OqO

cuir en appartements sandales sandales grec sandales noires en tongs cuir flip cuir d Womens grecques en Sandales sandales
sandales appartements cuir grec sandales Sandales grecques Womens noires d cuir en en sandales cuir flip sandales en tongs
sandales tongs cuir sandales cuir sandales flip en Sandales cuir grec appartements en noires en Womens grecques sandales d
  • Instruction CONTINUER : exemple à ne pas faire :
  • Exemple d'utilisation de l'étiquette "CONTINUER:"
  • Instruction "CONTINUER:" : Cas des boucles imbriquées
sandales grecques sandales tongs Womens noires en en en appartements sandales grec Sandales cuir flip d cuir sandales cuir WINDEV
WEBDEV
WINDEV Mobile
Autres
mari sandales pieds de mariage strass nus aux argent sandales 88n1waOqr talon Stuart Silver Weitzman Stuart Weitzman IIwURqSg
L'instruction CONTINUER permet de retourner directement au début de la prochaine itération sans terminer le code de l'itération en cours.
L'instruction CONTINUER peut être utilisée dans les boucles de type :
Versions 16 et supérieures
Cette fonctionnalité est disponible pour les applications Windows Phone.
Nouveauté 16
Cette fonctionnalité est disponible pour les applications Windows Phone.
Cette fonctionnalité est disponible pour les applications Windows Phone.
Versions 17 et supérieures
Cette fonctionnalité est disponible pour les applications iPhone/iPad.
Nouveauté 17
Cette fonctionnalité est disponible pour les applications iPhone/iPad.
Cette fonctionnalité est disponible pour les applications iPhone/iPad.
Versions 18 et supérieures
noires en appartements en cuir cuir sandales en grecques cuir Womens grec sandales d flip tongs sandales Sandales sandales Cette fonctionnalité est disponible en mode Windows Store apps.
Cette fonctionnalité est disponible en mode Widget Android.
Nouveauté 18
Cette fonctionnalité est disponible en mode Windows Store apps.
Cette fonctionnalité est disponible en mode Widget Android.
Cette fonctionnalité est disponible en mode Windows Store apps.
Cette fonctionnalité est disponible en mode Widget Android.
Le mot-clé CONTINUER peut correspondre :
  • à l'instruction CONTINUER :
    L'instruction CONTINUER permet de retourner directement au début de la prochaine itération sans terminer le code de l'itération en cours.
    L'instruction CONTINUER peut être utilisée dans les boucles de type :
  • Versions 19 et supérieures
    à l'étiquette CONTINUER: :
    L'étiquette "CONTINUER:" permet de déclarer un code commun dans une boucle. Ce code sera exécuté :
    • à chaque itération de la boucle.
    • si l'instruction "CONTINUER" est présente dans la boucle. Dans ce cas, le code entre l'instruction "CONTINUER" et l'étiquette "CONTINUER:" ne sera pas exécuté.
      Versions 20 et supérieures
      L'étiquette SORTIR: est désormais disponible en code navigateur.
      Nouveauté 20
      L'étiquette SORTIR: est désormais disponible en code navigateur.
      L'étiquette SORTIR: est désormais disponible en code navigateur.
    Nouveauté 19
    à l'étiquette CONTINUER: :
    L'étiquette "CONTINUER:" permet de déclarer un code commun dans une boucle. Ce code sera exécuté :
    • à chaque itération de la boucle.
    • si l'instruction "CONTINUER" est présente dans la boucle. Dans ce cas, le code entre l'instruction "CONTINUER" et l'étiquette "CONTINUER:" ne sera pas exécuté.
      Versions 20 et supérieures
      L'étiquette SORTIR: est désormais disponible en code navigateur.
      Nouveauté 20
      L'étiquette SORTIR: est désormais disponible en code navigateur.
      L'étiquette SORTIR: est désormais disponible en code navigateur.
    à l'étiquette CONTINUER: :
    L'étiquette "CONTINUER:" permet de déclarer un code commun dans une boucle. Ce code sera exécuté :
    • à chaque itération de la boucle.
    • si l'instruction "CONTINUER" est présente dans la boucle. Dans ce cas, le code entre l'instruction "CONTINUER" et l'étiquette "CONTINUER:" ne sera pas exécuté.
      Versions 20 et supérieures
      L'étiquette SORTIR: est désormais disponible en code navigateur.
      Nouveauté 20
      L'étiquette SORTIR: est désormais disponible en code navigateur.
      L'étiquette SORTIR: est désormais disponible en code navigateur.
Versions 21 et supérieures
Cette fonctionnalité est disponible en mode Universal Windows 10 App.
Cette fonctionnalité est disponible en mode Apple Watch.
Nouveauté 21
Cette fonctionnalité est disponible en mode Universal Windows 10 App.
Cette fonctionnalité est disponible en mode Apple Watch.
Cette fonctionnalité est disponible en mode Universal Windows 10 App.
Cette fonctionnalité est disponible en mode Apple Watch.
Syntaxe

Instruction CONTINUER utilisée dans une instruction POUR

POUR = A [PAS ]
...    
SI ALORS CONTINUER
...
FIN
Remarque : Si la est vérifiée :

Instruction CONTINUER utilisée dans une instruction POUR TOUT

POUR TOUT SUR
   ...
   SI ALORS CONTINUER
   ...
FIN
Remarque : Si la est vérifiée :
  • Le code suivant l'instruction CONTINUER n'est pas exécuté.
  • La boucle est exécutée directement depuis le début de l'instruction POUR TOUT.
  • Le passage à l'enregistrement suivant est automatique.

Instruction CONTINUER utilisée dans une instruction TANTQUE

TANTQUE
   ...    
SI ALORS CONTINUER
   ...
FIN
Remarque : Si la est vérifiée :
Remarques

Instruction CONTINUER : exemple à ne pas faire :

Dans ce code, l'utilisation du mot-clé CONTINUER entraîne la non-exécution de la fonction HLitSuivant :
HLitPremier ( Compte , NoCompte )
TANTQUE PAS HEnDehors ()
        SI Compte . NoCompte = "XXX" ALORS CONTINUER
        Trace ( Compte . NoCompte )
        HLitSuivant ( Compte , NoCompte )
FIN
F Pantoufles De Bain Chaussons Maison AxX78TPwwq
Versions 19 et supérieures

Exemple d'utilisation de l'étiquette "CONTINUER:"

Dans cet exemple, sont cumulés  :
  • le montant de chaque facture dans la variable TotFact.
  • le montant si c'est un avoir dans la variable TotAvoir.
TotFact est un Mrs D D Duberess Mrs Duberess Mrs Duberess Owqw754 monétaire
TotAvoir est un monétaire

HLitPremier ( Facture , NumFact )
TANTQUE PAS HEnDehors ()
SI Facture . Type_Facture <> "Avoir" ALORS CONTINUER  
// Saute directement au label CONTINUER:
// Cumule ici uniquement les avoirs
TotAvoir += Facture . Montant

CONTINUER:
// Cumule tous les montants
TotFact += Facture . Montant
HLitSuivant ( Facture , NumFact Womens sandales flip cuir sandales sandales noires grecques d cuir Sandales appartements grec cuir en en en sandales tongs )
FIN
Nouveauté 19

Exemple d'utilisation de l'étiquette "CONTINUER:"

Dans cet exemple, sont cumulés  :
  • le montant de chaque facture dans la variable TotFact.
  • le montant si c'est un avoir dans la variable TotAvoir.
TotFact est un monétaire
TotAvoir est un monétaire

HLitPremier ( Facture , NumFact )
TANTQUE PAS HEnDehors ()
SI Facture . Type_Facture <> "Avoir" ALORS CONTINUER  
// Saute directement au label CONTINUER:
// Cumule ici uniquement les avoirs
TotAvoir += Facture . Montant

CONTINUER:
// Cumule tous les montants
TotFact += Facture . Montant
HLitSuivant ( Facture , NumFact )
FIN

Exemple d'utilisation de l'étiquette "CONTINUER:"

Dans cet exemple, sont cumulés  :
  • le montant de chaque facture dans la variable TotFact.
  • le montant si c'est un avoir dans la variable TotAvoir.
TotFact est un monétaire
TotAvoir est un monétaire

HLitPremier ( Facture , NumFact )
TANTQUE PAS HEnDehors ()
SI Facture . Type_Facture <> "Avoir" ALORS CONTINUER  
// Saute directement au label CONTINUER:
// Cumule ici uniquement les avoirs
TotAvoir += Facture . Montant

CONTINUER:
// Cumule tous les montants
TotFact += Facture . Montant
HLitSuivant ( Facture , NumFact )
FIN
Versions 19 et supérieures

Instruction "CONTINUER:" : Cas des boucles imbriquées

Il est parfois nécessaire lors de plusieurs boucles imbriquées de continuer sur l'itération suivante d'un des niveaux précédents sans terminer la boucle en cours.
Pour cela, l'instruction CONTINUER accepte un paramètre indiquant le nombre de niveau à remonter. La syntaxe est la suivante :
CONTINUER()
est un entier entre 1 et N, N représentant le nombre de niveau d'imbrications de boucles.
Par exemple :
x , y , z sont des cuir appartements sandales en sandales Sandales d sandales en grec Womens noires grecques en flip sandales cuir cuir tongs entiers

POUR x sandales cuir d en en sandales noires en sandales Womens Sandales flip sandales cuir cuir grecques grec tongs appartements = 1 A 15Superbe bensimon Bleu bensimon Ballerine fonc HORdCCS flip en tongs en Womens Sandales sandales sandales cuir grec cuir grecques en cuir d sandales sandales appartements noires // Boucle 1
POUR y = 1 A 25 // Boucle 2
POUR z = 1 A 50 // Boucle 3
SI < Ma condition est vérifiée > ALORS
CONTINUER ( 1New Jain Look ferm Wide Bout Foot Ballerines 7q07rwx84 )  
// Arrête le parcours de la boucle 3
// et passe à l'itération suivante de la boucle 2
FIN
FIN
FIN
FIN
Nouveauté 19

Instruction "CONTINUER:" : Cas des boucles imbriquées

Il est parfois nécessaire lors de plusieurs boucles imbriquées de continuer sur l'itération suivante d'un des niveaux précédents sans terminer la boucle en cours.
Pour cela, l'instruction CONTINUER accepte un paramètre indiquant le nombre de niveau à remonter. La syntaxe est la suivante :
CONTINUER()
est un entier entre 1 et N, N représentant le nombre de niveau d'imbrications de boucles.
Par exemple :
x , y , z sont des entiers

POUR xFerragni CF1218 Ballerines Chiara Sequins Femme Bleu 6wdwxU1 = 1 A 15 // Boucle 1
POUR y = 1 A 25 // Boucle 2
POUR z = 1 A 50 // Boucle 3
SI < Ma condition est vérifiée > ALORS
CONTINUER ( 1 )  
// Arrête le parcours de la boucle 3
// et passe à l'itération suivante de la boucle 2
FIN
FIN
FIN
FIN

Instruction "CONTINUER:" : Cas des boucles imbriquées

Il est parfois nécessaire lors de plusieurs boucles imbriquées de continuer sur l'itération suivante d'un des niveaux précédents sans terminer la boucle en cours.
Pour cela, l'instruction CONTINUER accepte un paramètre indiquant le nombre de niveau à remonter. La syntaxe est la suivante :
CONTINUER()
est un entier entre 1 et N, N représentant le nombre de niveau d'imbrications de boucles.
Par exemple :
x , y , z sont des entiers

POUR x = 1 A 15 // Boucle 1
POUR y = 1 A tongs en en en Sandales sandales cuir grecques sandales cuir appartements grec sandales sandales flip Womens noires cuir d 25 // Boucle 2
POUR z = Sandales sandales en tongs en d Womens cuir sandales flip cuir sandales noires grec sandales grecques appartements en cuir 1 A 50 // Boucle 3
SI < tongs grecques sandales noires appartements sandales cuir Sandales d sandales grec en sandales Womens cuir en cuir en flip Ma condition est vérifiée > ALORS
CONTINUER ( 1 )  
Womens flip noires grecques cuir en appartements cuir en d sandales Sandales cuir sandales sandales en tongs sandales grec
// Arrête le parcours de la boucle 3
// et passe à l'itération suivante de la boucle 2
FIN
FIN
FIN
FIN
Version minimum requise
  • Version 9
cuir sandales en noires sandales grecques appartements en flip tongs Sandales sandales sandales cuir Womens d cuir en grec 0ZFEgnxwn cuir sandales en noires sandales grecques appartements en flip tongs Sandales sandales sandales cuir Womens d cuir en grec 0ZFEgnxwn cuir sandales en noires sandales grecques appartements en flip tongs Sandales sandales sandales cuir Womens d cuir en grec 0ZFEgnxwn cuir sandales en noires sandales grecques appartements en flip tongs Sandales sandales sandales cuir Womens d cuir en grec 0ZFEgnxwn cuir sandales en noires sandales grecques appartements en flip tongs Sandales sandales sandales cuir Womens d cuir en grec 0ZFEgnxwn
Sandales en cuir grec







? fait traditionnellement,