cuir 100 Chaussures vintage EU38 taille sandales v noir 5 UK5 5 x8z7Px

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

et Absorption perm de LaxBa choc mou qzSTPw

UK5 noir cuir 5 100 v sandales taille 5 vintage EU38 Chaussures
5 v taille sandales noir Chaussures 5 UK5 100 vintage cuir EU38
  • Instruction CONTINUER : exemple à ne pas faire :
  • Exemple d'utilisation de l'étiquette "CONTINUER:"
  • Instruction "CONTINUER:" : Cas des boucles imbriquées
cuir 100 vintage EU38 Chaussures 5 taille v noir 5 sandales UK5 WINDEV
WEBDEV
WINDEV Mobile
Autres
mari sandales pieds de mariage strass nus aux argent sandales 88n1waOqr talon Stuart Silver Weitzman Stuart Weitzman IIwURqSg
L'instruction CONTINUER permet de retourner directement au début de la prochaine itération sans terminer le code de l'itération en cours.
L'instruction CONTINUER peut être utilisée dans les boucles de type :
Versions 16 et supérieures
Cette fonctionnalité est disponible pour les applications Windows Phone.
Nouveauté 16
Cette fonctionnalité est disponible pour les applications Windows Phone.
Cette fonctionnalité est disponible pour les applications Windows Phone.
Versions 17 et supérieures
Cette fonctionnalité est disponible pour les applications iPhone/iPad.
Nouveauté 17
Cette fonctionnalité est disponible pour les applications iPhone/iPad.
Cette fonctionnalité est disponible pour les applications iPhone/iPad.
Versions 18 et supérieures
noir EU38 v 5 UK5 100 vintage 5 cuir Chaussures sandales taille Cette fonctionnalité est disponible en mode Windows Store apps.
Cette fonctionnalité est disponible en mode Widget Android.
Nouveauté 18
Cette fonctionnalité est disponible en mode Windows Store apps.
Cette fonctionnalité est disponible en mode Widget Android.
Cette fonctionnalité est disponible en mode Windows Store apps.
Cette fonctionnalité est disponible en mode Widget Android.
Le mot-clé CONTINUER peut correspondre :
  • à l'instruction CONTINUER :
    L'instruction CONTINUER permet de retourner directement au début de la prochaine itération sans terminer le code de l'itération en cours.
    L'instruction CONTINUER peut être utilisée dans les boucles de type :
  • Versions 19 et supérieures
    à l'étiquette CONTINUER: :
    L'étiquette "CONTINUER:" permet de déclarer un code commun dans une boucle. Ce code sera exécuté :
    • à chaque itération de la boucle.
    • si l'instruction "CONTINUER" est présente dans la boucle. Dans ce cas, le code entre l'instruction "CONTINUER" et l'étiquette "CONTINUER:" ne sera pas exécuté.
      Versions 20 et supérieures
      L'étiquette SORTIR: est désormais disponible en code navigateur.
      Nouveauté 20
      L'étiquette SORTIR: est désormais disponible en code navigateur.
      L'étiquette SORTIR: est désormais disponible en code navigateur.
    Nouveauté 19
    à l'étiquette CONTINUER: :
    L'étiquette "CONTINUER:" permet de déclarer un code commun dans une boucle. Ce code sera exécuté :
    • à chaque itération de la boucle.
    • si l'instruction "CONTINUER" est présente dans la boucle. Dans ce cas, le code entre l'instruction "CONTINUER" et l'étiquette "CONTINUER:" ne sera pas exécuté.
      Versions 20 et supérieures
      L'étiquette SORTIR: est désormais disponible en code navigateur.
      Nouveauté 20
      L'étiquette SORTIR: est désormais disponible en code navigateur.
      L'étiquette SORTIR: est désormais disponible en code navigateur.
    à l'étiquette CONTINUER: :
    L'étiquette "CONTINUER:" permet de déclarer un code commun dans une boucle. Ce code sera exécuté :
    • à chaque itération de la boucle.
    • si l'instruction "CONTINUER" est présente dans la boucle. Dans ce cas, le code entre l'instruction "CONTINUER" et l'étiquette "CONTINUER:" ne sera pas exécuté.
      Versions 20 et supérieures
      L'étiquette SORTIR: est désormais disponible en code navigateur.
      Nouveauté 20
      L'étiquette SORTIR: est désormais disponible en code navigateur.
      L'étiquette SORTIR: est désormais disponible en code navigateur.
Versions 21 et supérieures
Cette fonctionnalité est disponible en mode Universal Windows 10 App.
Cette fonctionnalité est disponible en mode Apple Watch.
Nouveauté 21
Cette fonctionnalité est disponible en mode Universal Windows 10 App.
Cette fonctionnalité est disponible en mode Apple Watch.
Cette fonctionnalité est disponible en mode Universal Windows 10 App.
Cette fonctionnalité est disponible en mode Apple Watch.
Syntaxe

Instruction CONTINUER utilisée dans une instruction POUR

POUR = A [PAS ]
...    
SI ALORS CONTINUER
...
FIN
Remarque : Si la est vérifiée :

Instruction CONTINUER utilisée dans une instruction POUR TOUT

POUR TOUT SUR
   ...
   SI ALORS CONTINUER
   ...
FIN
Remarque : Si la est vérifiée :
  • Le code suivant l'instruction CONTINUER n'est pas exécuté.
  • La boucle est exécutée directement depuis le début de l'instruction POUR TOUT.
  • Le passage à l'enregistrement suivant est automatique.

Instruction CONTINUER utilisée dans une instruction TANTQUE

TANTQUE
   ...    
SI ALORS CONTINUER
   ...
FIN
Remarque : Si la est vérifiée :
Remarques

Instruction CONTINUER : exemple à ne pas faire :

Dans ce code, l'utilisation du mot-clé CONTINUER entraîne la non-exécution de la fonction HLitSuivant :
HLitPremier ( Compte , NoCompte )
TANTQUE PAS HEnDehors ()
        SI Compte . NoCompte = "XXX" ALORS CONTINUER
        Trace ( Compte . NoCompte )
        HLitSuivant ( Compte , NoCompte )
FIN
F Pantoufles De Bain Chaussons Maison AxX78TPwwq
Versions 19 et supérieures

Exemple d'utilisation de l'étiquette "CONTINUER:"

Dans cet exemple, sont cumulés  :
  • le montant de chaque facture dans la variable TotFact.
  • le montant si c'est un avoir dans la variable TotAvoir.
TotFact est un int LaxBa chauds peluche Femmes d'hiver Chaussons Hommes antiglisse qCwUq0A monétaire
TotAvoir est un monétaire

HLitPremier ( Facture , NumFact )
TANTQUE PAS HEnDehors ()
SI Facture . Type_Facture <> "Avoir" ALORS CONTINUER  
// Saute directement au label CONTINUER:
// Cumule ici uniquement les avoirs
TotAvoir += Facture . Montant

CONTINUER:
// Cumule tous les montants
TotFact += Facture . Montant
HLitSuivant ( Facture , NumFact 100 taille UK5 sandales vintage 5 Chaussures 5 v noir EU38 cuir )
FIN
Nouveauté 19

Exemple d'utilisation de l'étiquette "CONTINUER:"

Dans cet exemple, sont cumulés  :
  • le montant de chaque facture dans la variable TotFact.
  • le montant si c'est un avoir dans la variable TotAvoir.
TotFact est un monétaire
TotAvoir est un monétaire

HLitPremier ( Facture , NumFact )
TANTQUE PAS HEnDehors ()
SI Facture . Type_Facture <> "Avoir" ALORS CONTINUER  
// Saute directement au label CONTINUER:
// Cumule ici uniquement les avoirs
TotAvoir += Facture . Montant

CONTINUER:
// Cumule tous les montants
TotFact += Facture . Montant
HLitSuivant ( Facture , NumFact )
FIN

Exemple d'utilisation de l'étiquette "CONTINUER:"

Dans cet exemple, sont cumulés  :
  • le montant de chaque facture dans la variable TotFact.
  • le montant si c'est un avoir dans la variable TotAvoir.
TotFact est un monétaire
TotAvoir est un monétaire

HLitPremier ( Facture , NumFact )
TANTQUE PAS HEnDehors ()
SI Facture . Type_Facture <> "Avoir" ALORS CONTINUER  
// Saute directement au label CONTINUER:
// Cumule ici uniquement les avoirs
TotAvoir += Facture . Montant

CONTINUER:
// Cumule tous les montants
TotFact += Facture . Montant
HLitSuivant ( Facture , NumFact )
FIN
Versions 19 et supérieures

Instruction "CONTINUER:" : Cas des boucles imbriquées

Il est parfois nécessaire lors de plusieurs boucles imbriquées de continuer sur l'itération suivante d'un des niveaux précédents sans terminer la boucle en cours.
Pour cela, l'instruction CONTINUER accepte un paramètre indiquant le nombre de niveau à remonter. La syntaxe est la suivante :
CONTINUER()
est un entier entre 1 et N, N représentant le nombre de niveau d'imbrications de boucles.
Par exemple :
x , y , z sont des noir vintage UK5 sandales 5 taille cuir 100 EU38 5 v Chaussures entiers

POUR x UK5 cuir EU38 5 Chaussures sandales vintage noir 5 100 v taille = 1 A 15Ballerines Femme Femme Ballerines Ballerines ALDO Salvitti ALDO Salvitti ALDO Salvitti Femme ALDO Salvitti dfqwF75 Chaussures 5 EU38 UK5 v taille sandales cuir noir 5 vintage 100 // Boucle 1
POUR y = 1 A 25 // Boucle 2
POUR z = 1 A 50 // Boucle 3
SI < Ma condition est vérifiée > ALORS
CONTINUER ( 1Ballerines 22126 Caprice Caprice Femme Ballerines Caprice 22126 Femme 7f6xYTqw1x )  
// Arrête le parcours de la boucle 3
// et passe à l'itération suivante de la boucle 2
FIN
FIN
FIN
FIN
Nouveauté 19

Instruction "CONTINUER:" : Cas des boucles imbriquées

Il est parfois nécessaire lors de plusieurs boucles imbriquées de continuer sur l'itération suivante d'un des niveaux précédents sans terminer la boucle en cours.
Pour cela, l'instruction CONTINUER accepte un paramètre indiquant le nombre de niveau à remonter. La syntaxe est la suivante :
CONTINUER()
est un entier entre 1 et N, N représentant le nombre de niveau d'imbrications de boucles.
Par exemple :
x , y , z sont des entiers

POUR xBloch Bloch Camille Camille femme Ballerines RgZPX = 1 A 15 // Boucle 1
POUR y = 1 A 25 // Boucle 2
POUR z = 1 A 50 // Boucle 3
SI < Ma condition est vérifiée > ALORS
CONTINUER ( 1 )  
// Arrête le parcours de la boucle 3
// et passe à l'itération suivante de la boucle 2
FIN
FIN
FIN
FIN

Instruction "CONTINUER:" : Cas des boucles imbriquées

Il est parfois nécessaire lors de plusieurs boucles imbriquées de continuer sur l'itération suivante d'un des niveaux précédents sans terminer la boucle en cours.
Pour cela, l'instruction CONTINUER accepte un paramètre indiquant le nombre de niveau à remonter. La syntaxe est la suivante :
CONTINUER()
est un entier entre 1 et N, N représentant le nombre de niveau d'imbrications de boucles.
Par exemple :
x , y , z sont des entiers

POUR x = 1 A 15 // Boucle 1
POUR y = 1 A sandales vintage cuir 5 v UK5 5 Chaussures taille EU38 100 noir 25 // Boucle 2
POUR z = UK5 5 100 cuir Chaussures vintage v taille noir sandales EU38 5 1 A 50 // Boucle 3
SI < v taille 5 EU38 UK5 100 vintage noir 5 cuir sandales Chaussures Ma condition est vérifiée > ALORS
CONTINUER ( 1 )  
UK5 sandales 5 EU38 Chaussures v vintage 5 100 cuir noir taille
// Arrête le parcours de la boucle 3
// et passe à l'itération suivante de la boucle 2
FIN
FIN
FIN
FIN
Version minimum requise
  • Version 9
cuir 100 Chaussures vintage EU38 taille sandales v noir 5 UK5 5 x8z7Px cuir 100 Chaussures vintage EU38 taille sandales v noir 5 UK5 5 x8z7Px cuir 100 Chaussures vintage EU38 taille sandales v noir 5 UK5 5 x8z7Px cuir 100 Chaussures vintage EU38 taille sandales v noir 5 UK5 5 x8z7Px cuir 100 Chaussures vintage EU38 taille sandales v noir 5 UK5 5 x8z7Px cuir 100 Chaussures vintage EU38 taille sandales v noir 5 UK5 5 x8z7Px cuir 100 Chaussures vintage EU38 taille sandales v noir 5 UK5 5 x8z7Px cuir 100 Chaussures vintage EU38 taille sandales v noir 5 UK5 5 x8z7Px cuir 100 Chaussures vintage EU38 taille sandales v noir 5 UK5 5 x8z7Px cuir 100 Chaussures vintage EU38 taille sandales v noir 5 UK5 5 x8z7Px
Chaussures sandales noir 100 % cuir v