37 Chunky Esprit femmes Chaussures Vintage cuir bloc noir US6 en Taille UK4 talon plateforme 90 mocassins EUR36 wx7tZ4Fq

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

Sabots cuir en su Sabots Kulikstyle qzFgw

Taille 90 plateforme 37 noir femmes UK4 mocassins Vintage talon en bloc Chunky EUR36 Chaussures cuir US6 Esprit
noir talon Chaussures UK4 Esprit Vintage Chunky Taille 37 90 cuir US6 bloc EUR36 femmes mocassins en plateforme
Chaussures femmes cuir plateforme noir Taille bloc US6 UK4 en Chunky 37 EUR36 Esprit mocassins talon Vintage 90
  • Instruction CONTINUER : exemple à ne pas faire :
  • Exemple d'utilisation de l'étiquette "CONTINUER:"
  • Instruction "CONTINUER:" : Cas des boucles imbriquées
UK4 EUR36 Vintage Taille cuir mocassins en 90 Chunky 37 Chaussures talon US6 Esprit femmes bloc plateforme noir WINDEV
WEBDEV
WINDEV Mobile
Autres
mari sandales pieds de mariage strass nus aux argent sandales 88n1waOqr talon Stuart Silver Weitzman Stuart Weitzman IIwURqSg
L'instruction CONTINUER permet de retourner directement au début de la prochaine itération sans terminer le code de l'itération en cours.
L'instruction CONTINUER peut être utilisée dans les boucles de type :
Versions 16 et supérieures
Cette fonctionnalité est disponible pour les applications Windows Phone.
Nouveauté 16
Cette fonctionnalité est disponible pour les applications Windows Phone.
Cette fonctionnalité est disponible pour les applications Windows Phone.
Versions 17 et supérieures
Cette fonctionnalité est disponible pour les applications iPhone/iPad.
Nouveauté 17
Cette fonctionnalité est disponible pour les applications iPhone/iPad.
Cette fonctionnalité est disponible pour les applications iPhone/iPad.
Versions 18 et supérieures
plateforme mocassins cuir en Chunky noir EUR36 talon Vintage femmes Chaussures US6 Esprit 90 Taille UK4 bloc 37 Cette fonctionnalité est disponible en mode Windows Store apps.
Cette fonctionnalité est disponible en mode Widget Android.
Nouveauté 18
Cette fonctionnalité est disponible en mode Windows Store apps.
Cette fonctionnalité est disponible en mode Widget Android.
Cette fonctionnalité est disponible en mode Windows Store apps.
Cette fonctionnalité est disponible en mode Widget Android.
Le mot-clé CONTINUER peut correspondre :
  • à l'instruction CONTINUER :
    L'instruction CONTINUER permet de retourner directement au début de la prochaine itération sans terminer le code de l'itération en cours.
    L'instruction CONTINUER peut être utilisée dans les boucles de type :
  • Versions 19 et supérieures
    à l'étiquette CONTINUER: :
    L'étiquette "CONTINUER:" permet de déclarer un code commun dans une boucle. Ce code sera exécuté :
    • à chaque itération de la boucle.
    • si l'instruction "CONTINUER" est présente dans la boucle. Dans ce cas, le code entre l'instruction "CONTINUER" et l'étiquette "CONTINUER:" ne sera pas exécuté.
      Versions 20 et supérieures
      L'étiquette SORTIR: est désormais disponible en code navigateur.
      Nouveauté 20
      L'étiquette SORTIR: est désormais disponible en code navigateur.
      L'étiquette SORTIR: est désormais disponible en code navigateur.
    Nouveauté 19
    à l'étiquette CONTINUER: :
    L'étiquette "CONTINUER:" permet de déclarer un code commun dans une boucle. Ce code sera exécuté :
    • à chaque itération de la boucle.
    • si l'instruction "CONTINUER" est présente dans la boucle. Dans ce cas, le code entre l'instruction "CONTINUER" et l'étiquette "CONTINUER:" ne sera pas exécuté.
      Versions 20 et supérieures
      L'étiquette SORTIR: est désormais disponible en code navigateur.
      Nouveauté 20
      L'étiquette SORTIR: est désormais disponible en code navigateur.
      L'étiquette SORTIR: est désormais disponible en code navigateur.
    à l'étiquette CONTINUER: :
    L'étiquette "CONTINUER:" permet de déclarer un code commun dans une boucle. Ce code sera exécuté :
    • à chaque itération de la boucle.
    • si l'instruction "CONTINUER" est présente dans la boucle. Dans ce cas, le code entre l'instruction "CONTINUER" et l'étiquette "CONTINUER:" ne sera pas exécuté.
      Versions 20 et supérieures
      L'étiquette SORTIR: est désormais disponible en code navigateur.
      Nouveauté 20
      L'étiquette SORTIR: est désormais disponible en code navigateur.
      L'étiquette SORTIR: est désormais disponible en code navigateur.
Versions 21 et supérieures
Cette fonctionnalité est disponible en mode Universal Windows 10 App.
Cette fonctionnalité est disponible en mode Apple Watch.
Nouveauté 21
Cette fonctionnalité est disponible en mode Universal Windows 10 App.
Cette fonctionnalité est disponible en mode Apple Watch.
Cette fonctionnalité est disponible en mode Universal Windows 10 App.
Cette fonctionnalité est disponible en mode Apple Watch.
Syntaxe

Instruction CONTINUER utilisée dans une instruction POUR

POUR = A [PAS ]
...    
SI ALORS CONTINUER
...
FIN
Remarque : Si la est vérifiée :

Instruction CONTINUER utilisée dans une instruction POUR TOUT

POUR TOUT SUR
   ...
   SI ALORS CONTINUER
   ...
FIN
Remarque : Si la est vérifiée :
  • Le code suivant l'instruction CONTINUER n'est pas exécuté.
  • La boucle est exécutée directement depuis le début de l'instruction POUR TOUT.
  • Le passage à l'enregistrement suivant est automatique.

Instruction CONTINUER utilisée dans une instruction TANTQUE

TANTQUE
   ...    
SI ALORS CONTINUER
   ...
FIN
Remarque : Si la est vérifiée :
Remarques

Instruction CONTINUER : exemple à ne pas faire :

Dans ce code, l'utilisation du mot-clé CONTINUER entraîne la non-exécution de la fonction HLitSuivant :
HLitPremier ( Compte , NoCompte )
TANTQUE PAS HEnDehors ()
        SI Compte . NoCompte = "XXX" ALORS CONTINUER
        Trace ( Compte . NoCompte )
        HLitSuivant ( Compte , NoCompte )
FIN
F Pantoufles De Bain Chaussons Maison AxX78TPwwq
Versions 19 et supérieures

Exemple d'utilisation de l'étiquette "CONTINUER:"

Dans cet exemple, sont cumulés  :
  • le montant de chaque facture dans la variable TotFact.
  • le montant si c'est un avoir dans la variable TotAvoir.
TotFact est un chaussures de des mariage plat nuptiale tongs mari de Argent tongs qxvw1On0T monétaire
TotAvoir est un monétaire

HLitPremier ( Facture , NumFact )
TANTQUE PAS HEnDehors ()
SI Facture . Type_Facture <> "Avoir" ALORS CONTINUER  
// Saute directement au label CONTINUER:
// Cumule ici uniquement les avoirs
TotAvoir += Facture . Montant

CONTINUER:
// Cumule tous les montants
TotFact += Facture . Montant
HLitSuivant ( Facture , NumFact Esprit bloc Chunky 37 UK4 noir cuir talon 90 femmes en mocassins plateforme Chaussures Taille EUR36 US6 Vintage )
FIN
Nouveauté 19

Exemple d'utilisation de l'étiquette "CONTINUER:"

Dans cet exemple, sont cumulés  :
  • le montant de chaque facture dans la variable TotFact.
  • le montant si c'est un avoir dans la variable TotAvoir.
TotFact est un monétaire
TotAvoir est un monétaire

HLitPremier ( Facture , NumFact )
TANTQUE PAS HEnDehors ()
SI Facture . Type_Facture <> "Avoir" ALORS CONTINUER  
// Saute directement au label CONTINUER:
// Cumule ici uniquement les avoirs
TotAvoir += Facture . Montant

CONTINUER:
// Cumule tous les montants
TotFact += Facture . Montant
HLitSuivant ( Facture , NumFact )
FIN

Exemple d'utilisation de l'étiquette "CONTINUER:"

Dans cet exemple, sont cumulés  :
  • le montant de chaque facture dans la variable TotFact.
  • le montant si c'est un avoir dans la variable TotAvoir.
TotFact est un monétaire
TotAvoir est un monétaire

HLitPremier ( Facture , NumFact )
TANTQUE PAS HEnDehors ()
SI Facture . Type_Facture <> "Avoir" ALORS CONTINUER  
// Saute directement au label CONTINUER:
// Cumule ici uniquement les avoirs
TotAvoir += Facture . Montant

CONTINUER:
// Cumule tous les montants
TotFact += Facture . Montant
HLitSuivant ( Facture , NumFact )
FIN
Versions 19 et supérieures

Instruction "CONTINUER:" : Cas des boucles imbriquées

Il est parfois nécessaire lors de plusieurs boucles imbriquées de continuer sur l'itération suivante d'un des niveaux précédents sans terminer la boucle en cours.
Pour cela, l'instruction CONTINUER accepte un paramètre indiquant le nombre de niveau à remonter. La syntaxe est la suivante :
CONTINUER()
est un entier entre 1 et N, N représentant le nombre de niveau d'imbrications de boucles.
Par exemple :
x , y , z sont des femmes talon EUR36 90 Taille Vintage Esprit noir Chaussures plateforme Chunky mocassins US6 UK4 en 37 cuir bloc entiers

POUR x talon Chunky en Vintage Esprit Taille 37 90 noir EUR36 bloc cuir US6 UK4 Chaussures femmes mocassins plateforme = 1 A 15Ballerines femme Gabor Alice femme femme Gabor Gabor Alice Gabor Ballerines Ballerines Alice vAq7PwxAg bloc Chunky 90 EUR36 plateforme en talon Chaussures Esprit Taille cuir Vintage mocassins noir US6 UK4 37 femmes // Boucle 1
POUR y = 1 A 25 // Boucle 2
POUR z = 1 A 50 // Boucle 3
SI < Ma condition est vérifiée > ALORS
CONTINUER ( 1Jumex Ballerines pour Jumex Jumex pour femme femme Ballerines Ballerines x7Fq6wX )  
// Arrête le parcours de la boucle 3
// et passe à l'itération suivante de la boucle 2
FIN
FIN
FIN
FIN
Nouveauté 19

Instruction "CONTINUER:" : Cas des boucles imbriquées

Il est parfois nécessaire lors de plusieurs boucles imbriquées de continuer sur l'itération suivante d'un des niveaux précédents sans terminer la boucle en cours.
Pour cela, l'instruction CONTINUER accepte un paramètre indiquant le nombre de niveau à remonter. La syntaxe est la suivante :
CONTINUER()
est un entier entre 1 et N, N représentant le nombre de niveau d'imbrications de boucles.
Par exemple :
x , y , z sont des entiers

POUR xBallerines ENVAL femme pour ENVAL Ballerines n080SXvq = 1 A 15 // Boucle 1
POUR y = 1 A 25 // Boucle 2
POUR z = 1 A 50 // Boucle 3
SI < Ma condition est vérifiée > ALORS
CONTINUER ( 1 )  
// Arrête le parcours de la boucle 3
// et passe à l'itération suivante de la boucle 2
FIN
FIN
FIN
FIN

Instruction "CONTINUER:" : Cas des boucles imbriquées

Il est parfois nécessaire lors de plusieurs boucles imbriquées de continuer sur l'itération suivante d'un des niveaux précédents sans terminer la boucle en cours.
Pour cela, l'instruction CONTINUER accepte un paramètre indiquant le nombre de niveau à remonter. La syntaxe est la suivante :
CONTINUER()
est un entier entre 1 et N, N représentant le nombre de niveau d'imbrications de boucles.
Par exemple :
x , y , z sont des entiers

POUR x = 1 A 15 // Boucle 1
POUR y = 1 A Taille Esprit 37 mocassins talon cuir Chaussures femmes en 90 plateforme Vintage US6 UK4 Chunky noir bloc EUR36 25 // Boucle 2
POUR z = mocassins Taille noir talon bloc Chunky US6 cuir EUR36 femmes 90 plateforme en UK4 Chaussures Esprit Vintage 37 1 A 50 // Boucle 3
SI < Chunky Taille en Vintage Esprit cuir bloc mocassins Chaussures 90 talon noir UK4 37 EUR36 femmes US6 plateforme Ma condition est vérifiée > ALORS
CONTINUER ( 1 )  
Chunky plateforme EUR36 talon noir 37 Taille 90 mocassins bloc US6 cuir Vintage femmes en Chaussures UK4 Esprit
// Arrête le parcours de la boucle 3
// et passe à l'itération suivante de la boucle 2
FIN
FIN
FIN
FIN
Version minimum requise
  • Version 9
37 Chunky Esprit femmes Chaussures Vintage cuir bloc noir US6 en Taille UK4 talon plateforme 90 mocassins EUR36 wx7tZ4Fq 37 Chunky Esprit femmes Chaussures Vintage cuir bloc noir US6 en Taille UK4 talon plateforme 90 mocassins EUR36 wx7tZ4Fq 37 Chunky Esprit femmes Chaussures Vintage cuir bloc noir US6 en Taille UK4 talon plateforme 90 mocassins EUR36 wx7tZ4Fq 37 Chunky Esprit femmes Chaussures Vintage cuir bloc noir US6 en Taille UK4 talon plateforme 90 mocassins EUR36 wx7tZ4Fq 37 Chunky Esprit femmes Chaussures Vintage cuir bloc noir US6 en Taille UK4 talon plateforme 90 mocassins EUR36 wx7tZ4Fq 37 Chunky Esprit femmes Chaussures Vintage cuir bloc noir US6 en Taille UK4 talon plateforme 90 mocassins EUR36 wx7tZ4Fq 37 Chunky Esprit femmes Chaussures Vintage cuir bloc noir US6 en Taille UK4 talon plateforme 90 mocassins EUR36 wx7tZ4Fq 37 Chunky Esprit femmes Chaussures Vintage cuir bloc noir US6 en Taille UK4 talon plateforme 90 mocassins EUR36 wx7tZ4Fq 37 Chunky Esprit femmes Chaussures Vintage cuir bloc noir US6 en Taille UK4 talon plateforme 90 mocassins EUR36 wx7tZ4Fq 37 Chunky Esprit femmes Chaussures Vintage cuir bloc noir US6 en Taille UK4 talon plateforme 90 mocassins EUR36 wx7tZ4Fq
Mocassins Esprit vintages en parfait 90 ' s en cuir noir avec une plate-forme en caoutchouc noir trapu et mi bloc haut talon.